summaryrefslogtreecommitdiff
path: root/wasm-game-of-life/Cargo.toml
diff options
context:
space:
mode:
authorJordan Gong <jordan.gong@protonmail.com>2020-09-21 20:12:02 +0800
committerJordan Gong <jordan.gong@protonmail.com>2020-09-21 20:12:02 +0800
commit7b6356dfd243858a2d810f43e133b995fb89276f (patch)
tree46d24880de0b2c62314eafe757eecca215238291 /wasm-game-of-life/Cargo.toml
parenta1a8008aab6a1c70ed2a5ecde9d2f3ad21b689bf (diff)
Play around WebAssemblyHEADmaster
Diffstat (limited to 'wasm-game-of-life/Cargo.toml')
-rw-r--r--wasm-game-of-life/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/wasm-game-of-life/Cargo.toml b/wasm-game-of-life/Cargo.toml
new file mode 100644
index 0000000..8fc6c9a
--- /dev/null
+++ b/wasm-game-of-life/Cargo.toml
@@ -0,0 +1,37 @@
+[package]
+name = "wasm-game-of-life"
+version = "0.1.0"
+authors = ["Jordan Gong <jordan.gong@protonmail.com>"]
+edition = "2018"
+
+[lib]
+crate-type = ["cdylib", "rlib"]
+
+[features]
+default = ["console_error_panic_hook"]
+
+[dependencies]
+wasm-bindgen = "0.2.63"
+
+# The `console_error_panic_hook` crate provides better debugging of panics by
+# logging them with `console.error`. This is great for development, but requires
+# all the `std::fmt` and `std::panicking` infrastructure, so isn't great for
+# code size when deploying.
+console_error_panic_hook = { version = "0.1.6", optional = true }
+
+# `wee_alloc` is a tiny allocator for wasm that is only ~1K in code size
+# compared to the default allocator's ~10K. It is slower than the default
+# allocator, however.
+#
+# Unfortunately, `wee_alloc` requires nightly Rust when targeting wasm for now.
+wee_alloc = { version = "0.4.5", optional = true }
+
+[dev-dependencies]
+wasm-bindgen-test = "0.3.13"
+
+[profile.release]
+# Tell `rustc` to optimize for small code size.
+opt-level = "s"
+
+[package.metadata.wasm-pack.profile.release]
+wasm-opt = ["-Oz", "--enable-mutable-globals"] \ No newline at end of file